Baselayer

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
IRS TIN Matching
Resolved·Full outage

IRS TIN matching has recovered.

Sat, Jul 4, 2026, 08:45 PM
(10 hours ago)
·
Affected components
Jul 4, 2026, 11:45 AM
08:45 PM
TIN Match
Updates

Resolved

IRS TIN matching has recovered.

Sat, Jul 4, 2026, 08:45 PM

Monitoring

Conditions are improving. Continuing to monitor.

Sat, Jul 4, 2026, 02:45 PM(6 hours earlier)

Monitoring

Conditions have worsened. We continue to monitor.

Sat, Jul 4, 2026, 12:45 PM(2 hours earlier)

Monitoring

IRS TIN matching is currently impacted. We are monitoring.

Sat, Jul 4, 2026, 11:45 AM(1 hour earlier)