Baselayer

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
IRS TIN Matching
Resolved·Partial outage

IRS TIN matching has recovered.

Sat, May 30, 2026, 12:15 AM
(23 hours ago)
·
Affected components
May 29, 2026, 10:02 PM
May 30, 2026, 12:15 AM
TIN Match
Updates

Resolved

IRS TIN matching has recovered.

Sat, May 30, 2026, 12:15 AM

Monitoring

Conditions have worsened. We continue to monitor.

Fri, May 29, 2026, 11:03 PM(1 hour earlier)

Monitoring

IRS TIN matching is experiencing elevated failures. We are monitoring.

Fri, May 29, 2026, 10:02 PM(1 hour earlier)