Resolved
IRS TIN Matching services have been restored to fully operational. Backlogged TIN matches from the duration of the outage and being processed to completion.
Identified
Extended latency from IRS on TIN matching. All TIN verifications will be retried when available.