Resolved
Baselayer services have returned to fully operational and outstanding requests are being fulfilled.
Monitoring
Baselayer engineers have recovered the queue failure and are working to process all outstanding requests
Investigating
Baselayer requests are experiencing high latency or failing to complete due to an upstream issue with our cloud provider. Engineering is working with the provider to identify a fix.